Unleash your computer's power : install the OsiriX 64-bit extension and fully exploit the power of your processors.


 


Important Notice

MacOS 10.9 requires Osirix 5.8 or OsiriX MD 2.8 (or higher)

Previous versions of OsiriX are NOT compatible with MacOS 10.9

 

Old Versions:

OsiriX5.0.2.dmg
(Compatible with MacOS 10.7, incompatible with MacOS 10.9 or higher)

OsiriX4.1.2-Int.pkg.zip
(Compatible with MacOS 10.6, incompatible with MacOS 10.9 or higher)

OsiriX4.0-Int.pkg.zip
(Compatible with MacOS 10.5, incompatible with MacOS 10.9 or higher)